RemovePathReinforcementSystem Method


Path Reinforcement Remove Path Reinforcement System Method

Deletes the specified PathReinforcement, and converts its RebarInSystem elements to equivalent Rebar elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<ElementId> RemovePathReinforcementSystem(
	Document doc,
	PathReinforcement system
)

Parameters

doc Document
The document.
system PathReinforcement
A PathReinforcement element in the document.

Return Value

IList ElementId
The ids of the newly created Rebar elements.
Exceptions
Exception Condition
ArgumentException The element system was not found in the given document. -or- system does not host Rebar.
ArgumentNullException A non-optional argument was null
See Also