ExternalEventRequest Enumeration


External Event Request Enumeration

Represents the possible outcomes of a request for raising an external event.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ExternalEventRequest
Members
Member name Value Description
Accepted 0 Request accepted; event was added into the event queue and will be executed momentarily.
Denied 2 Request was denied due to failures of the corresponding event handler.
Pending 1 Request not accepted, because the previous request is still pending (not executed).
TimedOut 3 Request not accepted due to synchronization issues with other thread(s).
See Also