BuiltInFailures.DuctFailures Class


Built In Failures Duct Failures Class

Failures about Duct.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures DuctFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class DuctFailures

The BuiltInFailures DuctFailures type exposes the following members.

Properties
Name Description
Public property Static member CannotCreateGeometryForDuct Cannot create geometry for flex duct. The flex duct is intersecting itself or the start and end are too close together.
Public property Static member FlexDuctLengthOutOfLimits The flex duct length of [Length Value] exceeds the maximum specified length of [Maximum Flex Duct Length Value]
Public property Static member NoDuctFittingsInProject There are no duct fittings defined in project. The default duct type for fittings will be set to none.
Public property Static member PartNotFoundDueToNoDuctConnectedError "In order to find a matching part, the fitting has to be connected to a duct."
Public property Static member PartNotFoundDueToNoDuctConnectedWarning "In order to find a matching part, the fitting has to be connected to a duct."
Top
See Also