ElementIsCurveDrivenFilter Class


Element Is Curve Driven Filter Class

A filter used to match elements which are curve driven.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementIsCurveDrivenFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementIsCurveDrivenFilter : ElementQuickFilter

The ElementIsCurveDrivenFilter type exposes the following members.

Constructors
Name Description
Public method ElementIsCurveDrivenFilter Constructs a new instance of a filter to match only curve driven elements.
Public method ElementIsCurveDrivenFilter(Boolean) Constructs a new instance of a filter to match only curve driven elements, with the option to match all elements which are not curve driven elements.
Top
Properties
Name Description
Top
Methods
Name Description
Top
Remarks
The term "curve driven" indicates that the element's Location property is a LocationCurve. Example elements found by this filter include walls, beams, and curve elements. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also