WorkflowFile Property


Systems Analysis Options Workflow File Property

The file name of the EnergyPlus workflow script.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public string WorkflowFile { get; set; }

Property Value

String
Exceptions
Exception Condition
ArgumentException When setting this property: The analysis requires a valid workflow file path or the empty string.
ArgumentNullException When setting this property: A non-optional argument was null
Remarks
When requesting a new system analysis, it is okay to have an empty workflowFile in the SystemsAnalysisOption. In that case, the ViewSystemsAnalysisReport would supply the weather file with the default value "HVAC Systems Loads and Sizing.osw".
See Also