IsEnabledByContext Property


Ribbon Button Is Enabled By Context Property

Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsEnabledByContext { get; }

Property Value

Boolean
Remarks
The button may be enabled for a given context but still disabled programmatically using the Enabled property for the button.
See Also