Key |
This class contains the results and status information regarding an attempt to load the KeyBasedTreeEntries from an External Resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The KeyBasedTreeEntriesLoadResults type exposes the following members.

Name | Description | |
---|---|---|
![]() | KeyBasedTreeEntriesLoadResults | Creates an empty KeyBasedTreeEntriesLoadResults. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the KeyBasedTreeEntriesLoadResults |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetFailureMessages | Get all error or warnings created while attempting to load KeyBasedTreeEntries. |
![]() | GetFileReadErrors | Gets the names of any files which could not be read due to access errors. |
![]() | GetFileSyntaxErrors | Gets all the records in the key-based tree data text file that could not be parsed into KeyBasedTreeEntries. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetKeyBasedTreeEntryErrors | Gets information about KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors. |
![]() | GetKeyBasedTreeEntryErrors(KeyBasedTreeEntryErrorType) | Gets information about specific KeyBasedTreeEntry objects that could not be included in the KeyBasedTreeEntries object due to errors of a particular type. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

A KeyBasedTreeEntriesLoadResults object is returned by the KeynoteTable or AssemblyCodeTable API methods LoadFrom() and Reload() so that callers can determine whether the KeynoteTable or AssemblyCodeTable was updated successfully and what, if any, errors occurred.