AddInIdAttribute Class


Add In Id Attribute Class

The custom AddInId attribute for Macros macros use only.
Inheritance Hierarchy
System Object
System Attribute
Autodesk.Revit.DB.Macros AddInIdAttribute

Namespace: Autodesk.Revit.DB.Macros
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AddInIdAttribute : Attribute

The AddInIdAttribute type exposes the following members.

Constructors
Name Description
Public method AddInIdAttribute Constructs a new AddInIdAttribute.
Top
Properties
Name Description
Public property TypeId When implemented in a derived class, gets a unique identifier for this Attribute .
(Inherited from Attribute )
Public property Value AddInId guid value.
Top
Methods
Name Description
Public method Equals Returns a value that indicates whether this instance is equal to a specified object.
(Inherited from Attribute )
Public method GetHashCode Returns the hash code for this instance.
(Inherited from Attribute )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsDefaultAttribute When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class.
(Inherited from Attribute )
Public method Match When overridden in a derived class, returns a value that indicates whether this instance equals a specified object.
(Inherited from Attribute )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also