LevelAssociationData Class


Level Association Data Class

This class holds information related to Level.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB LevelAssociationData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LevelAssociationData : IDisposable

The LevelAssociationData type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the LevelAssociationData
Public method GetAssociatedLevel Returns the Associated Level id.
Public method Static member GetLevelAssociationData Returns LevelAssociationData associated with this element, if it exists.
Public method GetLevelOffset Returns the offset from the Associated Level.
Public method SetAssociatedLevel Sets the Associated Level.
Top
See Also