ConduitSize Constructor


Conduit Size Constructor

Constructs an object that stores the basic size information for conduit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ConduitSize(
	double nominalDiameter,
	double innerDiameter,
	double outerDiameter,
	double bendRadius,
	bool usedInSizeLists,
	bool usedInSizing
)

Parameters

nominalDiameter Double
Nominal diameter. The value should be a valid, positive Revit length.
innerDiameter Double
Inner diameter. The value should be a valid, positive Revit length.
outerDiameter Double
Outer diameter. The value should be a valid, positive Revit length.
bendRadius Double
Minimum bend radius. The value should be a valid, positive Revit length.
usedInSizeLists Boolean
Whether it is used in size lists.
usedInSizing Boolean
Whether is used in sizing.
Exceptions
Exception Condition
ArgumentOutOfRangeException The given value for nominalDiameter must be greater than 0 and no more than 30000 feet. -or- The given value for innerDiameter must be greater than 0 and no more than 30000 feet. -or- The given value for outerDiameter must be greater than 0 and no more than 30000 feet. -or- The given value for bendRadius must be greater than 0 and no more than 30000 feet.
See Also