TransactWithCentralOptions Class


Transact With Central Options Class

Options to customize Revit behavior when accessing the central model.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB TransactWithCentralOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class TransactWithCentralOptions : IDisposable

The TransactWithCentralOptions type exposes the following members.

Constructors
Name Description
Public method TransactWithCentralOptions Constructs a new TransactWithCentralOptions.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the TransactWithCentralOptions
Public method GetLockCallback Gets the callback object that changes Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.
Public method SetLockCallback Sets or resets a callback object that would allow an external application to change Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.
Top
See Also