ElementReferenceType Enumeration


Element Reference Type Enumeration

Element reference types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ElementReferenceType
Members
Member name Value Description
REFERENCE_TYPE_CUT_EDGE 5 The reference is to a face that was cut (where the original pick was made on the cut edge).
REFERENCE_TYPE_FOREIGN 3 The reference is to geometry or elements in linked Revit file.
REFERENCE_TYPE_INSTANCE 4 The reference is an instance of a symbol.
REFERENCE_TYPE_LINEAR 1 The reference is to a curve or edge.
REFERENCE_TYPE_MESH 6 The reference is to a mesh.
REFERENCE_TYPE_NONE 0 The reference is to an element.
REFERENCE_TYPE_SUBELEMENT 7 The reference is to a subelement.
REFERENCE_TYPE_SURFACE 2 The reference is to a face or face region.
See Also