StructuralSectionColdFormed Class


Structural Section Cold Formed Class

Defines parameters for Hot Formed structural section.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class StructuralSectionColdFormed : StructuralSectionRectangular

The StructuralSectionColdFormed type exposes the following members.

Properties
Name Description
Public property AnalysisParams Common set of parameters for structural analysis.
(Inherited from StructuralSection )
Public property CentroidHorizontal Distance from centroid to the left extremites along horizontal axis.
(Inherited from StructuralSectionRectangular )
Public property CentroidVertical Distance from centroid to the upper extremites along vertical axis.
(Inherited from StructuralSectionRectangular )
Public property ElasticModulusStrongAxis Elastic section modulus about main strong axis for calculation of bending stresses.
(Inherited from StructuralSection )
Public property ElasticModulusWeakAxis Elastic section modulus about main weak axis for calculation of bending stresses.
(Inherited from StructuralSection )
Public property Height Section height, depth.
(Inherited from StructuralSectionRectangular )
Public property InnerFillet Inner Fillet - Corner fillet inner radius.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from StructuralSection )
Public property MomentOfInertiaStrongAxis Moment of Inertia about main strong axis (I).
(Inherited from StructuralSection )
Public property MomentOfInertiaWeakAxis Moment of Inertia about main weak axis (I).
(Inherited from StructuralSection )
Public property NameKey Name Key
(Inherited from StructuralSectionRectangular )
Public property NominalWeight Unit weight (not mass) per unit length, for self-weight calculation or quantity survey.
(Inherited from StructuralSection )
Public property Perimeter Painting surface of the unit length.
(Inherited from StructuralSection )
Public property PlasticModulusStrongAxis Plastic section modulus in bending about main strong axis (Z, Wpl).
(Inherited from StructuralSection )
Public property PlasticModulusWeakAxis Plastic section modulus in bending about main weak axis.
(Inherited from StructuralSection )
Public property PrincipalAxesAngle Rotation angle between the principal axes and cross section reference planes.
(Inherited from StructuralSection )
Public property SectionArea Cross section area.
(Inherited from StructuralSection )
Public property SectionNameKey A parameter in structural families which allows for family type identification. This will be used for data mapping during model exchange with another program, namely Advance Steel.
(Inherited from StructuralSection )
Public property ShearAreaStrongAxis Shear area (reduced extreme shear stress coefficient) in the direction of strong axis (Wq).
(Inherited from StructuralSection )
Public property ShearAreaWeakAxis Shear area (reduced extreme shear stress coefficient) in the direction of weak axis (Wq).
(Inherited from StructuralSection )
Public property StructuralSectionGeneralShape The general type of structural section shape.
(Inherited from StructuralSection )
Public property StructuralSectionShape The type of structural section shape.
(Inherited from StructuralSection )
Public property StructuralSectionShapeName A human readable string representing the structural section shape.
(Inherited from StructuralSection )
Public property TorsionalModulus Section modulus for calculations of torsion stresses (Ct).
(Inherited from StructuralSection )
Public property TorsionalMomentOfInertia Torsional Moment of inertia (J, IT, K), for calculation of torsional deformation
(Inherited from StructuralSection )
Public property WallDesignThickness Represents wall design thickness of rectangle.
Public property WallNominalThickness Represents wall nominal thickness of rectangle.
Public property WarpingConstant Warping constant (Cw, Iomega, H).
(Inherited from StructuralSection )
Public property Width Section width.
(Inherited from StructuralSectionRectangular )
Top
Methods
Name Description
Public method Dispose
(Inherited from StructuralSection )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetBoundarySize Returns size of the section boundary.
(Inherited from StructuralSection )
Public method GetEnumerator
(Inherited from StructuralSection )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also
Inheritance Hierarchy