Family |
Create a model text in the Autodesk Revit family document.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public ModelText NewModelText(
string text,
ModelTextType modelTextType,
SketchPlane sketchPlane,
XYZ position,
HorizontalAlign horizontalAlign,
double depth
)
Parameters
- text String
- The text to be displayed.
- modelTextType ModelTextType
- The type of model text. If this parameter is , the default type will be used.
- sketchPlane SketchPlane
- The sketch plane of the model text. The direction of model text is determined by the normal of the sketch plane. To extrude in the other direction set the depth value to negative.
- position XYZ
- The position of the model text. The position must lie in the sketch plane.
- horizontalAlign HorizontalAlign
- The horizontal alignment.
- depth Double
- The depth of the model text.
Return Value
ModelTextIf successful, the newly created model text is returned, otherwise an exception with error information will be thrown.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument text, sketchPlane or XYZ is . |
ArgumentException | Thrown when input argument text is an empty string. Thrown when input argument horizontalAlign or depth is invalid. |
InvalidOperationException | Thrown when model text creation failed. |