CanRebarBeSpliced(Rebar, RebarSpliceOptions, RebarSpliceGeometry) Method


Rebar Splice Utils Can Rebar Be Spliced(Rebar, Rebar Splice Options, Rebar Splice Geometry) Method

Verifies if the rebar can be spliced with the RebarSpliceGeometry.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static RebarSpliceError CanRebarBeSpliced(
	Rebar rebar,
	RebarSpliceOptions spliceOptions,
	RebarSpliceGeometry spliceGeometry
)

Parameters

rebar Rebar
The rebar to be spliced.
spliceOptions RebarSpliceOptions
The RebarSpliceOptions.
spliceGeometry RebarSpliceGeometry
The RebarSpliceGeometry.

Return Value

RebarSpliceError
Will return RebarSpliceError.Success if it's possible to splice with point or other enum value corresponding to the error that occurred.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also