SetLocationPathForSpiralRun Method


Stairs Run Set Location Path For Spiral Run Method

Set Location path for a spiral run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool SetLocationPathForSpiralRun(
	StairsRun stairsRun,
	XYZ center,
	double radius,
	double startAngle,
	double includedAngle,
	bool clockwise,
	StairsRunJustification justification
)

Parameters

stairsRun StairsRun
The run whose location path will be set.
center XYZ
The center of the location arc of the spiral run. The Z coordinate of the center is the base elevation for the new run (in model coordinates). It must be greater than or equal to the stairs base elevation.
radius Double
The radius of the location arc of the spiral run.
startAngle Double
The start angle of the location arc of the spiral run. The angle's coordinate system is world coordinate system which always is XYZ.BasisX and XYZ.BasisY.
includedAngle Double
The total angle covered by the spiral run. Must be a positive value (direction is determined by the clockwise flag).
clockwise Boolean
True if the spiral run will be created along clockwise direction, False otherwise.
justification StairsRunJustification
The location path justification of the new stairs run.

Return Value

Boolean
Indicate if set is success or not.
Exceptions
Exception Condition
ArgumentException The given value for startAngle is not finite -or- The input center is not a valid center for spiral run (probably the Z coordinate doesn't meet the restrictions) -or- The includedAngle doesn't satisfy riser restriction to generate spiral run (probably it's too small).
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The given value for radius must be greater than 0 and no more than 30000 feet. -or- The given value for includedAngle must be positive. -or- A value passed for an enumeration argument is not a member of that enumeration
ArgumentsInconsistentException The radius is too small to generate a spiral run at the given justification.
InvalidOperationException The stairs element represented by stairsRun is not in an active StairsEditScope. The run cannot be modified.
RegenerationFailedException The center, radius, startAngle, includedAngle don't satisfy restrictions to generate spiral run.
See Also