Point |
Creates a new hosted point load within the project.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static PointLoad Create(
Document document,
ElementId hostElemId,
AnalyticalElementSelector selector,
XYZ forceVector,
XYZ momentVector,
PointLoadType symbol
)
Parameters
- document Document
- Document to which new point load will be added.
- hostElemId ElementId
- The AnalyticalMember host element for the point Load.
- selector AnalyticalElementSelector
- The start or end point of the Analytical Member element.
- forceVector XYZ
- The applied 3d force vector.
- momentVector XYZ
- The applied 3d moment vector.
- symbol PointLoadType
- The symbol of the PointLoad. Set to use default type.
Return Value
PointLoadIf successful, returns the newly created PointLoad, otherwise.

Exception | Condition |
---|---|
ArgumentException | The element hostElemId does not exist in the document -or- hostElemId is not permitted for this type of load. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
ArgumentsInconsistentException | Thrown when force and moment vectors are equal zero. |
InvalidOperationException | Thrown if type could not be set for newly created point load. |