XYZ Multiply(XYZ, Double) Operator |
Multiplies the specified number and the specified vector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- left XYZ
- The vector to multiply with the value.
- value Double
- The value to multiply with the specified vector.
Return Value
XYZThe multiplied vector.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when source is . |
ArgumentException | Thrown when the specified value is an infinite number. |

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.