Data |
Predefined message ids for DataExchangeLog.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)


Member name | Value | Description |
---|---|---|
EmptyObject | 10 | A warning level message. The conversion encountered an object with no data to convert. The object will be ignored. This may indicate a problem with incoming data. |
GenericError | 6 | A catch-all error code. Used for errors that are not enumerated explicitly. |
InvalidDataSet | 5 | No data could be imported. Would typically be reported as a error. May be reported as a fatal error. |
InvalidRenderingStyle | 9 | An error message. The conversion code was unable to process a render style. The created model will differ in visual appearance. |
InvalidSourceObject | 4 | An error message. A source object was found to be invalid. |
None | 0 | No message. |
ObjectCreated | 2 | An informational message. An object - a face, edge, solid, etc. - has been created successfully. |
ObjectNotConverted | 8 | An error message. The conversion code was unable to process a valid supported source object. |
ObjectNotSupported | 7 | A warning message. A source object was not converted. |
UnexpectedResult | 3 | Unexpected result produced by a data conversion operation. Conversion may continue, but the results should be carefully reviewed. |
UnitOfProgressCompleted | 1 | That message will be sent at reasonable intervals to provide the using application an opportunity to update its progress indicator. |