KeynoteEntry Constructor (String, String, String)


Keynote Entry(String, String, String) Constructor

Constructs a new KeynoteEntry from the given key name, parent key name, and keynote text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public KeynoteEntry(
	string key,
	string parentKey,
	string text
)

Parameters

key String
The key of this KeynoteEntry.
parentKey String
The parent key of this KeynoteEntry. Empty string means this KeynoteEntry does not have a parent.
text String
The text associated with this KeynoteEntry
Exceptions
Exception Condition
ArgumentException key is an empty string.
ArgumentNullException A non-optional argument was null
See Also