CreateSubElementGUID Method


Exporter IFCUtils Create Sub Element GUID Method

Creates a consistent GUID for an IFC entity related to a Revit element. A "related" sub-element is one that is unique for a given type of element, and can therefore by identified by a simple index value (e.g. PSet_Wall_Common property set for a wall.) The index value 0 is reserved, as this would generate the GUID of the element itself. A listing of known sub-elements is contained in IFCSubElementEnums.cs; it is expected that this list would be maintained up-to-date, instead of passing arbitrary values into this function.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static string CreateSubElementGUID(
	Element pElement,
	int subElementIndex
)

Parameters

pElement Element
The element.
subElementIndex Int32
The global index for this sub-element.

Return Value

String
The guid string.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also