STEPExportOptions Class


STEPExport Options Class

The export options used by exporting STEP format file.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BIMExportOptions
Autodesk.Revit.DB STEPExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class STEPExportOptions : BIMExportOptions

The STEPExportOptions type exposes the following members.

Constructors
Name Description
Public method STEPExportOptions Constructs a new instance of STEPExportOptions with default values of all properties.
Top
Properties
Name Description
Public property ApplicationProtocol The Application Protocol of the exported STEP file.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from BIMExportOptions )
Public property TargetUnit The unit type of geometry in the resultant STEP file. Default value is ExportUnit::Default.
Public property ViewId The element id of the 3D view to export. InvalidElementId by default.
(Inherited from BIMExportOptions )
Top
Methods
Name Description
Public method Dispose
(Inherited from BIMExportOptions )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also