WorksetFilter Class


Workset Filter Class

A base class for a type of filter that accepts or rejects worksets based upon criteria.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class WorksetFilter : IDisposable

The WorksetFilter type exposes the following members.

Properties
Name Description
Public property IncludeStandaloneWorksetsOnly True if the results of the filter only match stand-alone worksets; worksets that are not stand-alone will be rejected.
Public property Inverted True if the results of the filter are inverted; worksets that would normally be accepted by this filter will be rejected, and worksets that would normally be rejected will be accepted.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the WorksetFilter
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also