IStructural |
The server's method that will be called when Revit User clicks the Section Type parameter's button in the family dialog.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- data StructuralSectionsServiceData
- The Section Type data.
Return Value
BooleanIndicates whether the section type parameter server is executed successfully.

The server provides UI way for Revit user to view and modify the detail data corresponding with the parameter value. The server may also modify the section type parameter value itself during the execution. The method should always return 'true' if the server is successfully executed, no matter whether the server changes anything. Return 'false' or if the server throws, indicates a failed case, all changes made by the server will be discarded.