Light |
This class represents a set of lights grouped together for easier management of various lighting scenarios

System Object
Autodesk.Revit.DB.Lighting LightGroup
Autodesk.Revit.DB.Lighting LightGroup
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The LightGroup type exposes the following members.

Name | Description | |
---|---|---|
![]() | Id | The ElementId of the LightGroup |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | Name | The name of the LightGroup |

Name | Description | |
---|---|---|
![]() | AddLight | Add a new light instance to the group |
![]() | Dispose | Releases all resources used by the LightGroup |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetLights | Get the set of contained light instances The set of light instances |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | RemoveLight | Remove the given light instance from the set of light instances in this group |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |