Parameter Can |
Tests whether this parameter can be associated with any global parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Return Value
BooleanTrue if the given parameter can be associated (is parametrizable); False otherwise.

Exception | Condition |
---|---|
ArgumentException | This parameter does not exist in the document anymore. |

Only properties defined as parametrizable can be associated with global parameters. That excludes any read-only and formula-driven parameters, as well as those that have other explicit or implicit restrictions imposed by Revit.