MetallicPaint Class


Metallic Paint Class

A static class that provides access to the property names that appear in the MetallicPaint visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual MetallicPaint

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class MetallicPaint

The MetallicPaint type exposes the following members.

Properties
Name Description
Public property Static member CommonTintColor The property labeled "Tint Color" from the "MetallicPaint" schema.
Public property Static member CommonTintToggle The property labeled "Tint" from the "MetallicPaint" schema.
Public property Static member MetallicpaintBaseColor The property labeled "Color" from the "MetallicPaint" schema.
Public property Static member MetallicpaintBaseColorByObject The property labeled "Color By Object" from the "MetallicPaint" schema.
Public property Static member MetallicpaintBaseHighlightspread The property labeled "Highlight Spread" from the "MetallicPaint" schema.
Public property Static member MetallicpaintFinish The property labeled "Finish" from the "MetallicPaint" schema.
Public property Static member MetallicpaintFinishPeelamount The property labeled "Amount" from the "MetallicPaint" schema.
Public property Static member MetallicpaintFlecks The property labeled "Flecks" from the "MetallicPaint" schema.
Public property Static member MetallicpaintFlecksColor The property labeled "Color" from the "MetallicPaint" schema.
Public property Static member MetallicpaintFlecksColorByObject The property labeled "Color By Object" from the "MetallicPaint" schema.
Public property Static member MetallicpaintFlecksSize The property labeled "Size" from the "MetallicPaint" schema.
Public property Static member MetallicpaintPearl The property labeled "Pearl" from the "MetallicPaint" schema.
Public property Static member MetallicpaintPearlAmount The property labeled "Amount" from the "MetallicPaint" schema.
Public property Static member MetallicpaintPearlColor The property labeled "Color" from the "MetallicPaint" schema.
Public property Static member MetallicpaintPearlColorByObject The property labeled "Color By Object" from the "MetallicPaint" schema.
Public property Static member MetallicpaintPearlIor The property labeled "Blend" from the "MetallicPaint" schema.
Public property Static member MetallicpaintTopcoat The property labeled "Top Coat" from the "MetallicPaint" schema.
Public property Static member MetallicpaintTopcoatFalloff The property labeled "Angle Falloff" from the "MetallicPaint" schema.
Public property Static member MetallicpaintTopcoatGlossy The property labeled "Glossiness" from the "MetallicPaint" schema.
Top
See Also