ConnectToUpstreamNode Method


Electrical Analytical Node Connect To Upstream Node Method

Connects to upstream node.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ConnectToUpstreamNode(
	ElementId upstreamNodeId
)

Parameters

upstreamNodeId ElementId
The upstream node id.
Exceptions
Exception Condition
ArgumentException The id is not an analytical distribution node id. -or- The analytical distribution node is full of downstream nodes. -or- The analytical distribution node can not connect to the upstream node.
ArgumentNullException A non-optional argument was null
InvalidOperationException The analytical distribution node is full of upstream nodes.
See Also