VertexStream Class


The base class for DirectContext3D vertex streams, which are used to write vertex data into buffers.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2017

Syntax

C#
public class VertexStream : IDisposable
Visual Basic
Public Class VertexStream _
	Implements IDisposable
Visual C++
public ref class VertexStream : IDisposable

Remarks

For each type of vertex (e.g., Autodesk::Revit::DB::DirectContext3D::VertexPositionNormal), there is a corresponding stream type. The process of putting vertex data into a buffer involves using a stream-buffer pair as follows (see Autodesk::Revit::DB::DirectContext3D::VertexBuffer).

  1. Map the vertex buffer.
  2. Get a stream of the appropriate type from the buffer.
  3. Add vertices of the same type to the stream. They will be written into the buffer that was used to create the stream.
  4. Unmap the buffer.

Alternatively to using streams, it is possible to write data into a buffer using a handle to its mapped memory.

Inheritance Hierarchy

See Also