Autodesk.Revit.DB.DirectContext3D Namespace


Classes

Class Description
Public class Camera
A collection of camera settings
Public class ClipPlane
A set of parameters representing a clip plane in DirectContext3D.
Public class DirectContext3DDocumentUtils
The methods provided by this utility class support the use of DirectContext3D and storage of DirectContext3D handle elements in Revit documents.
Public class DirectContext3DHandleOverrides
A set of DirectContext3DHandleSettings that are stored by a view.
Public class DirectContext3DHandleSettings
Overriding settings applied to DirectContext3DHandles through the Visibility dialog.
Public class DrawContext
A class that provides drawing functionality for use by DirectContext3D servers (see Autodesk::Revit::DB::DirectContext3D::IDirectContext3DServer).
Public class EffectInstance
An effect instance that controls the appearance of geometry.
Public class IndexBuffer
A buffer that stores vertex indices for rendering.
Public class IndexLine
A line segment primitive consisting of two indices.
Public class IndexPoint
A point primitive consisting of one index.
Public class IndexPrimitive
The base class for index buffer primitives.
Public class IndexStream
The base class for DirectContext3D index streams, which are used to write vertex indices into buffers.
Public class IndexStreamLine
A stream that can be used to write line segment primitives into a buffer (see Autodesk::Revit::DB::DirectContext3D::IndexBuffer).
Public class IndexStreamPoint
A stream that can be used to write point primitives into a buffer (see Autodesk::Revit::DB::DirectContext3D::IndexBuffer).
Public class IndexStreamTriangle
A stream that can be used to write triangle primitives into a buffer (see Autodesk::Revit::DB::DirectContext3D::IndexBuffer).
Public class IndexTriangle
A triangle primitive consisting of three indices.
Public class Vertex
The base class for DirectContext3D vertices.
Public class VertexBuffer
A buffer that stores vertex data for rendering.
Public class VertexFormat
A specification of the format of vertex data contained in a piece of geometry.
Public class VertexPosition
A geometry vertex specified as a position in space.
Public class VertexPositionColored
A geometry vertex specified as a position in space with a color.
Public class VertexPositionNormal
A geometry vertex specified as a position in space with a normal vector.
Public class VertexPositionNormalColored
A geometry vertex specified as a position in space with a normal vector and a color.
Public class VertexStream
The base class for DirectContext3D vertex streams, which are used to write vertex data into buffers.
Public class VertexStreamPosition
A stream that can be used to write vertices of type VertexPosition into a buffer (see Autodesk::Revit::DB::DirectContext3D::VertexBuffer).
Public class VertexStreamPositionColored
A stream that can be used to write vertices of type VertexPositionColored into a buffer (see Autodesk::Revit::DB::DirectContext3D::VertexBuffer).
Public class VertexStreamPositionNormal
A stream that can be used to write vertices of type VertexPositionNormal into a buffer (see Autodesk::Revit::DB::DirectContext3D::VertexBuffer).
Public class VertexStreamPositionNormalColored
A stream that can be used to write vertices of type VertexPositionNormalColored into a buffer (see Autodesk::Revit::DB::DirectContext3D::VertexBuffer).

Interfaces

Interface Description
Public interface IDirectContext3DServer
The interface to be implemented by a server of the DirectContext3D external service.

Enumerations

Enumeration Description
Public enumeration PrimitiveType
Type of geometry primitive represented as a number.
Public enumeration ProjectionMethod
Projection method
Public enumeration VertexFormatBits
Vertex format (i.e., the type of data associated with a vertex) represented as a number.