GetConnectedProperty Method (String)


Gets a connected property by its name.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2014

Syntax

C#
public AssetProperty GetConnectedProperty(
	string name
)
Visual Basic
Public Function GetConnectedProperty ( _
	name As String _
) As AssetProperty
Visual C++
public:
AssetProperty^ GetConnectedProperty(
	String^ name
)

Parameters

name
Type: System String
Name of the property.

Return Value

The property with the specified name.

Remarks

Returns NULL is there is no connected property with the specified name.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also