Retrieves basic file data.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- file
- Type: System String
The full path to the file to be queried.
Return Value
If successful, basic file data.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions FileArgumentNotFoundException | The file doesn't exist. |
Autodesk.Revit.Exceptions InvalidOperationException | A file is saved in very old version of Revit without basic file data. |