FilterDialog Constructor (Document, String)


Constructs a new instance of the FilterDialog class, while setting the name of the new ParameterFilterElement to be created and selected for editing.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public FilterDialog(
	Document doc,
	string name
)
Visual Basic
Public Sub New ( _
	doc As Document, _
	name As String _
)
Visual C++
public:
FilterDialog(
	Document^ doc, 
	String^ name
)

Parameters

doc
Type: Autodesk.Revit.DB Document
The document that owns the FilterElements displayed and edited in the dialog.
name
Type: System String
The user-visible name for the new ParameterFilterElement.

Remarks

Show the dialog with the Show() method after setting the desired options.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException name is an empty string. -or- name cannot include prohibited characters. -or- The given value for name is already in use as a filter element name.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also