GetRibbonPanels Method (Tab)


Get all the custom Panels on a designated standard Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public virtual List<RibbonPanel> GetRibbonPanels(
	Tab tab
)
Visual Basic
Public Overridable Function GetRibbonPanels ( _
	tab As Tab _
) As List(Of RibbonPanel)
Visual C++
public:
virtual List<RibbonPanel^>^ GetRibbonPanels(
	Tab tab
)

Parameters

tab
Type: Autodesk.Revit.UI Tab
The tab on which the panels are located.

Remarks

Built-in panels will not be included. This method is not supported in Macros.

See Also