PaneExists Method


Returns true if %id% refers to a dockable pane window that currently exists in the Revit user interface, whether it's hidden or shown.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public static bool PaneExists(
	DockablePaneId id
)
Visual Basic
Public Shared Function PaneExists ( _
	id As DockablePaneId _
) As Boolean
Visual C++
public:
static bool PaneExists(
	DockablePaneId^ id
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also