SetNonControlledTemplateParameterIds Method


Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public void SetNonControlledTemplateParameterIds(
	ICollection<ElementId> newSet
)
Visual Basic
Public Sub SetNonControlledTemplateParameterIds ( _
	newSet As ICollection(Of ElementId) _
)
Visual C++
public:
void SetNonControlledTemplateParameterIds(
	ICollection<ElementId^>^ newSet
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also