AddStackedItems Method (RibbonItemData, RibbonItemData)


Adds two stacked items to the panel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public IList<RibbonItem> AddStackedItems(
	RibbonItemData item1,
	RibbonItemData item2
)
Visual Basic
Public Function AddStackedItems ( _
	item1 As RibbonItemData, _
	item2 As RibbonItemData _
) As IList(Of RibbonItem)
Visual C++
public:
IList<RibbonItem^>^ AddStackedItems(
	RibbonItemData^ item1, 
	RibbonItemData^ item2
)

Parameters

item1
Type: Autodesk.Revit.UI RibbonItemData
Data containing information about the first item. This data must be of type PushButtonData, PulldownButtonData, ComboBoxData, or TextBoxData.
item2
Type: Autodesk.Revit.UI RibbonItemData
Data containing information about the second item. This data must be of type PushButtonData, PulldownButtonData, ComboBoxData, or TextBoxData.

Return Value

A collection containing the added items.

Remarks

Each new item may either be a PushButton, PulldownButton, ComboBox or TextBox, depending upon the type of data passed in for each argument. The new items will be created as small-size horizontal controls, with the first stacked on top of the second in the panel.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when item1 or item2 is a null reference ( Nothing in Visual Basic) .
Autodesk.Revit.Exceptions ArgumentException Thrown when an item with the item1.Name or item2.Name already exists in the panel or the data is not of the correct type.

See Also