Creates clean joins between two elements that share a common face.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document containing the two elements.
- firstElement
- Type: Autodesk.Revit.DB Element
The first element to be joined.
- secondElement
- Type: Autodesk.Revit.DB Element
The second element to be joined. This element must not be joined to the first element.
Remarks
The visible edge between joined elements is removed. The joined elements then share the same line weight and fill pattern. This functionality is not available for family documents.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | document is not a project document. -or- The document document does not contain the element firstElement -or- The document document does not contain the element secondElement -or- The elements are already joined. -or- The elements cannot be joined. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | Please remove or add segments on curtain grids instead of joining or unjoining geometry of the panels. |