Insert Method


Insert the specified reference into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public virtual void Insert(
	Reference item,
	int index
)
Visual Basic
Public Overridable Sub Insert ( _
	item As Reference, _
	index As Integer _
)
Visual C++
public:
virtual void Insert(
	Reference^ item, 
	int index
)

Parameters

item
Type: Autodesk.Revit.DB Reference
The reference to be inserted into the array.
index
Type: System Int32
The reference will be inserted before this index.

Return Value

Returns whether the reference was inserted into the array.

See Also