Indicates whether the specified point is within this face and outputs additional results.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- point
- Type: Autodesk.Revit.DB UV
The parameters to be evaluated, in natural parameterization of the face.
- result
- Type: Autodesk.Revit.DB IntersectionResult %
Provides more information when the point is on the edge; otherwise, a null reference ( Nothing in Visual Basic) .
Return Value
True if within this face, otherwise False.Remarks
The following is the meaning of the IntersectionResult members when the point is on the edge: EdgeObject is the edge that the point lies on; EdgeParameter is the parameter of the point on the edge nearest to the UV point; UV is the specified point.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when the parameter evaluation fails. |