Creates a new energy analysis detailed model.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document that contains the physical model of the building.
- options
- Type: Autodesk.Revit.DB.Analysis EnergyAnalysisDetailModelOptions
The options to control the calculation rules.
Return Value
The created model instance.Remarks
The generated energy model is always returned in world coordinates. The method TransformModel() transforms all surfaces in the model according to ground plane, shared coordinates and true north.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Throws if there are no valid spatial bounding elements, or no valid spatial elements in the document. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | Failed to create the energy analysis detail model. |
Autodesk.Revit.Exceptions OperationCanceledException | Throws if user aborted the energy analysis detail model creation. |