Creates new rooms in each plan circuit found in the given level in the given phase.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- level
- Type: Autodesk.Revit.DB Level
The level from which the circuits are found.
- phase
- Type: Autodesk.Revit.DB Phase
The phase on which the room is to exist.
Return Value
If successful, a set of ElementIds which contains the rooms should be returned, otherwise the exception will be thrown.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved. |
Autodesk.Revit.Exceptions InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation. |