ExternalServiceOptions Class


Various options affecting the behavior of an External Service

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public class ExternalServiceOptions : IDisposable
Visual Basic
Public Class ExternalServiceOptions _
	Implements IDisposable
Visual C++
public ref class ExternalServiceOptions : IDisposable

Remarks

Options are provided at the time of registering a service. After a service is registered, the options cannot be changed.

Inheritance Hierarchy

System Object
Autodesk.Revit.DB.ExternalService ExternalServiceOptions

See Also