Creates a new duct.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- systemTypeId
- Type: Autodesk.Revit.DB ElementId
The id of the HVAC system type.
- ductTypeId
- Type: Autodesk.Revit.DB ElementId
The id of the duct type.
- levelId
- Type: Autodesk.Revit.DB ElementId
The level id for the duct.
- firstPoint
- Type: Autodesk.Revit.DB XYZ
The first point of the duct.
- secondPoint
- Type: Autodesk.Revit.DB XYZ
The second point of the duct.
Return Value
The placeholder duct.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The systemTypeId is not valid HVAC system type. -or- The duct type ductTypeId is not valid duct type. -or- The level id levelId is not valid. -or- The points of firstPoint and secondPoint are equal. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |