Indicates if the provided orientation is permitted for this load.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- orientTo
- Type: Autodesk.Revit.DB.Structure LoadOrientTo
Load orientation to check.
Return Value
True if provided orientation type is permitted for this load, false if not.Remarks
For hosted load only LoadOrientTo.Project and LoadOrientTo.HostLocalCoordinateSystem are permitted. For non-hosted load only LoadOrientTo.Project and LoadOrientTo.WorkPlane are permitted. To determine if load is non-hosted check if HostElementId is ElementId.InvalidElementId. Otherwise load is hosted.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |