Calculates the intersection of the specified face with this face and returns the intersection results.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- face
- Type: Autodesk.Revit.DB Face
The specified face to intersect with this face.
- result
- Type: Autodesk.Revit.DB Curve %
A single Curve representing the intersection.
Return Value
- FaceIntersectionFaceResult.Intersecting - One or more intersections were encountered.
- SetComparisonResult.NonIntersecting - There is no intersection found.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | The face is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions InvalidOperationException | The intersection calculation fails. |