Creates a new sheet assembly view for the assembly instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document to which the view will be added.
- assemblyInstanceId
- Type: Autodesk.Revit.DB ElementId
Id of the assembly instance that owns the new view.
- titleBlockId
- Type: Autodesk.Revit.DB ElementId
Id of the titleblock family to use. For no titleblock, pass invalidElementId.
Return Value
A new sheet assembly view.Remarks
The document must be regenerated before using the sheet.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- titleBlockId is not a TitleBlock. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document has no open transaction. |