SetupDockablePane Method


Method called during initialization of the user interface to gather information about a dockable pane window.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
void SetupDockablePane(
	DockablePaneProviderData data
)
Visual Basic
Sub SetupDockablePane ( _
	data As DockablePaneProviderData _
)
Visual C++
void SetupDockablePane(
	DockablePaneProviderData^ data
)

Parameters

data
Type: Autodesk.Revit.UI DockablePaneProviderData
Container for information about the new dockable pane. Implementers should set the FrameworkElement and InitialState properties on the passed-in data object.

See Also