Creates a selector based on a specific analytical curve.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curve
- Type: Autodesk.Revit.DB Curve
The curve upon which this selector acts.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input curve points to a helical curve and is not supported for this operation. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |