AddItems Method


Adds new ToggleButtons to the RadioButtonGroup.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public IList<ToggleButton> AddItems(
	IList<ToggleButtonData> buttonData
)
Visual Basic
Public Function AddItems ( _
	buttonData As IList(Of ToggleButtonData) _
) As IList(Of ToggleButton)
Visual C++
public:
IList<ToggleButton^>^ AddItems(
	IList<ToggleButtonData^>^ buttonData
)

Parameters

buttonData
Type: System.Collections.Generic IList ToggleButtonData
A list of objects containing the data needed to construct the ToggleButtons.

Return Value

The newly added ToggleButtons.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when buttonData is a null reference ( Nothing in Visual Basic) .
Autodesk.Revit.Exceptions ArgumentException Thrown when button with buttonData.Name already exists in the group.

See Also